STL Preview Thumbnails

Discussion of ANY 3D printing topic you desire!
Post Reply
User avatar
Krishty
Reactions:
Posts: 29
Joined: December 3rd, 2017, 3:31 pm
Location: Germany
3D Printer(s): DaVinci
Contact:

STL Preview Thumbnails

Post by Krishty » May 31st, 2019, 5:22 pm

I have a hard time remembering file names, so I wrote a shell extension to display STL models right in the file icon in Windows File Explorer.

It proved very useful to me; if you want to give it a try: https://papas-best.com/stlthumbnails_en

Feedback is always welcome!

Image

User avatar
Krishty
Reactions:
Posts: 29
Joined: December 3rd, 2017, 3:31 pm
Location: Germany
3D Printer(s): DaVinci
Contact:

Re: STL Preview Thumbnails

Post by Krishty » June 10th, 2019, 8:51 am

I just found out that there’s problems with the thumbnails if UAC is disabled. If anyone has UAC off and doesn’t see any thumbnails, drop me a note and we’ll work it out. I’m looking into a fix.

User avatar
Roberts_Clif
Reactions:
Posts: 873
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: STL Preview Thumbnails

Post by Roberts_Clif » June 10th, 2019, 9:33 am

I have UAC turned off in Windows 7 Pro and Windows 8 Pro have never had any problems.
Will let you know if one arrives?
Electronics Technician / Computer Programmer

User avatar
Krishty
Reactions:
Posts: 29
Joined: December 3rd, 2017, 3:31 pm
Location: Germany
3D Printer(s): DaVinci
Contact:

Re: STL Preview Thumbnails

Post by Krishty » June 11th, 2019, 7:08 am

Roberts_Clif wrote:
June 10th, 2019, 9:33 am
I have UAC turned off in Windows 7 Pro and Windows 8 Pro have never had any problems.
Very useful insight! Could you please check whether HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA exists on your system, and if so, whether it is 0 or 1?

The problems on one user’s computer were related to a value of 0. If yours is not 0 although you have UAC turned off, maybe the problem is more related to Group Policies than to UAC itself.

I’ll sure tell you when a fix is ready – if I can fix such a thing at all.

By the way, today’s version fixes the small overlay Icons in the bottom-right of the thumbnail which are present for every file type but were missing from STLs in earlier thumbnail versions. And it fixes the orientation of exports from recent Solid Edge versions. Today is Microsoft Patch Day, so I recommend installing the handler now and postponing the restart until Windows updates are due.

User avatar
Roberts_Clif
Reactions:
Posts: 873
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

STL Preview Thumbnails

Post by Roberts_Clif » June 11th, 2019, 7:20 am

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA exists
Image2.jpg
EnableLUA exists on system, and it is 0
Electronics Technician / Computer Programmer

User avatar
LePaul
Reactions:
Posts: 3425
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): UM2+,CR-10S (x2),Tevo Tornado,FT-i3/FT-5/FT-6...
Contact:

Re: STL Preview Thumbnails

Post by LePaul » June 11th, 2019, 10:03 am

Microsoft as a big update to Windows 10 coming out soon, I read it can be downloaded now but coming soon to the update

User avatar
Krishty
Reactions:
Posts: 29
Joined: December 3rd, 2017, 3:31 pm
Location: Germany
3D Printer(s): DaVinci
Contact:

Re: STL Preview Thumbnails

Post by Krishty » June 11th, 2019, 11:10 am

Roberts_Clif wrote:
June 11th, 2019, 7:20 am
EnableLUA exists on system, and it is 0
Wow, that’s bad for me. The behavior on the other system was:
  1. Thumbnails didn’t work. Triple-checked all registry keys etc.
  2. User turned UAC on. Thumbnails started working.
  3. User turned UAC off. Thumbnails stopped working.
  4. According to Process Monitor, the HKEY_CURRENT_USER\Software\Classes registry branch was not mapped into HKEY_CLASSES_ROOT as soon as EnableLUA was on. This prevented Explorer from finding the STL preview handler key, although it appeared to be correct in regedit.
  5. Installing the thumbnails for all users on the machine (msiexec /i "Papas Best STL Thumbnails.msi" MSIINSTALLPERUSER="") fixed the problem.
This means they shouldn’t be working with UAC off as long as you don’t perform an all-users installation with the magic msiexec spell. Dang. I guess instead of ripping registry implementation details apart for another week, I should just say “if it works with UAC disabled, good for you; if it doesn’t, I have no clue“ :(

User avatar
Roberts_Clif
Reactions:
Posts: 873
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: STL Preview Thumbnails

Post by Roberts_Clif » June 11th, 2019, 5:14 pm

Ok!

I have worked with computers a long long time and sometimes things just go right for me.
Electronics Technician / Computer Programmer

User avatar
Krishty
Reactions:
Posts: 29
Joined: December 3rd, 2017, 3:31 pm
Location: Germany
3D Printer(s): DaVinci
Contact:

Re: STL Preview Thumbnails

Post by Krishty » August 10th, 2019, 1:42 pm

The thumbnails did not work in one of my virtual machines, and I finally found the bug and fixed it in the latest update.

I recommend everyone with similar problems tries it! https://papas-best.com/stlthumbnails_en

A registry key for MIME types was missing.

And just so you know, the STL Viewer’s Windows integretion improved also. It shows up correctly in the Select App to Open dialog and all that (together with the usual performance and stability improvements).

Post Reply

Return to “General 3D Printing Conversation”